제목 : Wim 파일 탑재 실습을 하여 보았습니다

선우

안녕하세요

즐거운 주말오후 만끽 하시고 계시는지요

저는 일전에 계획을 하고 있던 작업을 하여보게 되었습니다. 일전에 서기다 님께서 고수님께

배려받은 파일을 적용하여 W드라이브 마운트 되는것이 너무 부러워서 입문자도 서기다 님의

발자취를 쫒아서 가보게 되었습니다.

 

일단 서기다 님의 PE는 디볼트 계정이었고 제 자료는 어드민 계정 이어서 제대로 동작이 될까

의구심을 갖고 서기다 님께서 셋팅 해두신 그 값을 그대로 어드민 계정의 PE에 적용 해보게 되었습니다.

아래로 부족한 실습의 스크린샷을 올려 보았는데 다소 식상한 부분 이어도 많은 양해 바랍니다.

 

이런 신기하고 소중한 ini 파일을 구성 해주신 초 고수님께 머리숙여 감사의 인사를 드립니다.

 

클립보드1.jpg

적용후 첫 부팅에서 아~~ 실패구나 하고 탄식을 하고 있는데 오른쪽 아래 반가운 탑재중이란 맨트가 ...ㄷㄷㄷㄷㄷ 흥분되는 순간 이었습니다

 

클립보드2.jpg

탑재가 이루어지고 바탕화면에 원래 없던 아이콘들이 수북 생겼습니다 서기다 님께서 구성하셨던 PE-TOOL 속의 포터블 들이지요 작업 표시줄에도 부틱스와 T.DISM 이 새롭게 생성이 되어 있습니다 그런데 pecmd 아이콘이 트레이에 두개가 되었습니다 이 부분은 Y:\ppApps\SetFile\ImdiskInst.exe 이 경로의 실행파일 인 ImdiskInst.exe 가 실행되면서 생기는 아이콘 이었습니다

 

클립보드3.jpg

마운트 된 W드라이브를 확인하여 보았습니다 서기다 님께서 구성 해두신 peTools 폴더와 그 내용물 입니다  

 

클립보드4.jpg

서기다 님께선 디볼트 계정에서 pecmd.ini 마지막 부분에서 탑재가 시작이 되었는데 어드민 계정에선 SwitchToAdminLogon.ini 파일에서 실행을 해야 되는것 같습니다 부팅시 디볼트 계정에서 설정이 어드민으로 옮겨 오는데 이 파일이 pecmd.ini 와 같은 역활을 하는가 봅니다 "LOAD \ppApps\choice.ini" 항목은 서기다 님께서 작성 해놓으신 부분입니다

 

클립보드5.jpg

어드민으로 전환 되면서 SwitchToAdminLogon.ini 파일속 마지막에 로드된 choice.ini 에서 MultiTools.ini 를 실행 해주는가 봅니다 MultiTools.ini 이 파일이 바로 초초초 고수님께서 작성 해주신 파일 이지요 앞으로 한참을 공부해야할 참고서라 생각 합니다 초 고수님께 한번더 감사의 인사를 올림니다

 

클립보드6.jpg

우클릭 메뉴에 자동으로 등록된 탑재해제 메뉴를 눌러 보았는데 아마 경로 문제가 있는지 까만 화면이 되었는데 그 상황에서 Ctrl+Alt_Del 키를 누르고 로그 아웃을 시키니 저절로 어드민으로 로그인이 되면서 다시 초기 탑재를 하였습니다

  

클립보드8.jpg

peutil.wim 이 W드라이브로 마운트 되어 바탕화면에 아이콘이 출력된 상태로 원래 기능인 아이콘 출력을 해보니 정상대로 출력이 되어 집니다

 

클립보드9.jpg

탑재 아이콘 + 정상기능 아이콘 + 에피타이저 + 레인미터 + 로켓독 등등 모두 정상적으로 위치에 출력이 되어집니다

 

클립보드10.jpg

스냅피드라이버를 실행후 해상도를 잡아 보았는데 wim 탑재 후에도 정상대로 모니터가 잡혀줍니다

 

클립보드11.jpg

바탕화면 배경 전환하기 기능도 정상대로 잘 이루어 집니다

 

클립보드12.jpg

그런데 바탕화면 아이콘 보임/숨김 버튼을 눌러보니 탑재된 아이콘과 기본출력 아이콘 모두함께 사라집니다

 

클립보드13.jpg

탑재 해제를 누르면 이렇게 까만 화면으로 다운이 되어 버립니다 위에서 적은것 처럼  Ctrl+Alt_Del 키를 눌러서 로그아웃을 해주니 다시 탑재를 하였습니다 이 부분은 탑재 해제시 경로가 문제가 되는것이 아닌가 초보 입문자는 심각하게 생각 해보고 어려운 공부를 해야할 부분이군요

 

클립보드14.jpg

탑재된 w드라이브를 확인하여 보았습니다

 

클립보드15.jpg

서기다님 PE에서 실행시는 시작메뉴 화면에도 아이콘이 두개가 출력이 되는데 저는 아무것도 나오지 않습니다.

경로를 들어가 보니 디볼트 계정에 바로가기 아이콘이 두개가 생성되어 있습니다 스냅드라이버 아이콘은 제가 원래

wim 파일속 경로에 넣어 둔것입니다. 부팅전에 저 경로에 아이콘이 있다면 어드민 계정에서 넘겨 받겠지요

고수님이신 서기다 사부님과 계정이 다른 자료를 활용하여 적용 하려니 이런 문제에 봉착하게 됩니다.

 

이번엔 탑재가 된걸로 만족을 하고요 차후 공부를 해볼려고 합니다. 하지만 입문자의 머리로 대단히 어려운

문제 인것은 확실한것 같습니다. 이렇게 입문자는 고수님 따라 하기도 힘이든데 저걸 개발하신 초초초 고수님은

정말 생각만 해도 무시무시 합니다 ㄷㄷㄷㄷㄷ

 

입문자의 따라하기 실습 체험을 보아 주셔서 감사 드리고요 추후 조금씩 완성시켜 가보겠습니다.

즐거운 주말 저녁시간도 편안하신 시간으로 이어 지시길 바랍니다 감사합니다.

댓글 [64]

오빠는윈7

2017.09.23
21:37:31

우왕~ 멋집니다!

Seattle

2017.09.23
21:41:48

점점 좋아지는것 같습니다.

항상 감사합니다.

sboat123

2017.09.23
22:14:49

주말인데도 수고가 많으시네요...늘 감사합니다.

왕초보

2017.09.23
22:32:06

편안하게 쉬서야 할 토요일에도 이렇게 열공을 하고 계셨네요..

화이팅입니다..

 

추천요

parannara

2017.09.24
03:28:37

바쁘신 중에도 좋은 글 감사합니다.

수고하셨습니다.

s7h7o7w

2017.09.24
06:12:00

수고하셨습니다

검나조아

2017.09.24
07:54:07

수고하셨습니다.

l운l

2017.09.24
08:43:05

노력이 느껴지는 글입니다

고생하셧습니다

*자유인*

2017.09.24
09:36:57

수고 많으셨습니다. ^.^

고슴

2017.09.24
16:47:27

수고하셨습니다.^^

전저당께요

2017.09.24
23:37:39

수고가 많으십니다

밤톨이

2017.09.26
05:34:00

수고 하셨습니다.

잘보고 갑니다.

김사 합니다.

쏠로몬

2017.09.26
08:18:32

수고 하셨습니다 

디스텔

2017.09.27
09:40:15

수고하셨습니다.

List of Articles
[공지] 스크린샷 업로드 유의사항
XE1.11.6 Layout1.4.8