제목 : 우리두*님 PE에서 해상도 관련입니다..초보는 원인을 알수가 없네오.

왕초보

우리두*님께서...소개하여 주셨던...Win10PE_x64_RS5_BnR (17763.312)  관련입니다..

저의 경우..용량이 너무 착해서 감사의 사용기도 썼습니다...

사용기 댓글에...해상도 관련한 것과 pe 부팅시에 탐색기 메모리 읽기 오류 문제에 관한 댓글이 있습니다

 

저의 경우 탐색기 메모리읽기 관련은..어제 보기는 하였습니다만...재현이 안되네요..

해상도의 경우..저도..댓글을  달아 주신분과 같은 증상이어서..테스트도 하여 보고..PE 생성기로 PE가지 만들어 보았지만..

초보의 한계로 어떤 원인인지 알수가 없네요..

 

이번에 윈도우가 업데이트 되면서...뭔가 변화가 있었나 봅니다..PE 생성기가 RS3에서는 잘되었는데 RS4나 RS5에서 문제가 되었던것처럼

이번에도..그런가 봅니다

 

 

이미..이문제를 해결하신 분도 있으십니다...제니제스트님께서 트윅 사용기를 소개하여 주셔서 댓글에 아래처럼 질문을 드렸었습니다

 

0.png

 

0-1.png

 

 

역시..고수님들께서는 지식과 경험이 있으셔서..바로 문제를 해결을 하셨네요.

해상도 관련해서 도움이 필요하신분들을 제니제시트님께 도움을 청하셔야 할것 같습니다..

 

우리두*님께서..이 문제에 대해서..알고 계실것 같기도 합니다...우리두*님께서 문제를 해결하시면...다시 업데이트 버전을 소개를 하여 주실것

같습니다..

조금 기다려 보시는것도...괜찮을것 같습니다

 

 

아래는..저도 궁금해서...조금은 다르게 수정이 되었던..PE 생성기로 PE를 만들어 보았습니다

윈도우가 RS5 17763.312 버전에서는 같은 증상이 나타나네요...역시..뭔가 변화가 있었네요..

 

자료실에..XPE 업데이트 버전이 소개가 되고 있습니다...XPE로도 PE를 만들어 보아야 할것 같습니다.

 

윈도우가 RS5 17763.312 버전을 PE 생성기에서 PE를 만들었을때 이런 현상도 있구나 하고 참고만 하여 주십시요

 

 

 

1. 우리두*님과 다른 방식으로 수정이 되어서..boot.wim용량이 더 크게 나옵니다..그래도 기본은 같아서...윈도우 RS5 17763.312 버전으로 PE를

  만들어 보았습니다...우리두*님 작품처럼...레지스트리 간소화가 적용이 되었습니다.

1.png

 

2. 셋팅이 되어 있어서..툭딱 PE가 만들어져서 편하기는 합니다만...PE 생성기는 프로그램이 업데이트가 되지 않아서..이런 일이 있을때...참 곤란하네요

  윈도우가 316 버전입니다.

2.png

 

3. 저의 경우 아래 프로그램을 활용하고 있습니다.

3.png

 

4. 해상도 변경이 되었습니다..레인미터는 바로 자리를 잡았습니다... 하지만..배경화면과 StartIsBack은 그자리를 지키고 있습니다

   PE 생성기에서 만들어진 PE여서 같은 증상입니다..

   탐색기 새로 고침을 하여 보겠습니다... 우리두*님의 경우...PESET.exe Kill 명령으로 탐색기 재시작을 합니다..저의 경우.pecmd.exe Kill을 사용하고

  있습니다.

4.png

 

5. 탐색기가 재실행되면..아래처럼 적용이 되기는 합니다...해상도 변경시 마다 이렇게 사용할수는 없죠...

5.png

 

6. 저의 경우 StartIsBack64.dll 버전이 구버전입니다..

6.png

 

7. 이 문제가 아닌것은 이미 테스트 해서 알지만..최신 dll 파일로 교체를 하여 보았습니다... StartIsBack64.dll 파일만 교체했더니 설정이 조금 달라

  지네요...작업표시줄바가..투명이 아니라 파란색이 되었습니다..레지까지 정확히 바꾸어 주어야 하나 봅니다

7.png

 

8. StartIsBack 하고는 상관이 없나 봅니다...여전히 같은 현상이네요.

8.png

 

9. 다행히..이번에도 탐색기 재시작을 하면 적용이 되기는 합니다.....저야 잘 몰라서..해상도 프로그램 자체를 수정해볼까도 했습니다만...

  제니제스트님께서 해결을 하신것을 보면...pe에서 해결이 가능한가 봅니다..

9.png

 

10. 저의경우..pecmd.exe로 탐색기 재시작을 하고 있습니다...

10.png

 

11. 마무리

용량이 너무나 착한 PE를 선물을 받았습니다만...조금 아쉬운 부분들이 있죠..

저의 경우 PE 해상도를 1024*768로 사용하고 있어서...해상도 변경을 해보지 않아서 이런 현상이 있는줄도 몰랐습니다

댓글로 정보를 알려주신 분들께 감사드립니다...

 

해상도 관련해서 도움이 필요하신분들은..제니제스트님께 도움을 청하셔야 할것 같습니다..현재...그분만이 해결이 되셨네요..

아니면...우리두*님께서...해상도과..탐색기에서 메모리 오류가 나오는것을 해결하신 업데이트 버전을 소개하여 주실때까지..기다리시면 

되실것 같습니다..

 

PE생성기의 경우..프로그램을 만드신 고수님께서 업데이트를 해주시지 않으셔서 이런 문제가 생겼을때..해결이 쉽지 않죠..

아쉬운 부분입니다

 

이런 현상도 있구나 하고 참고하여 주십시요

 

웃음이 가득한 오후가 되시길 바랍니다

 

댓글 [9]

trillo2

2019.02.14
15:48:19

집념의 왕**님

정말 대단하십니다.

왕**님 덕분에 pecmd.ini 수정법도 많이 배웠습니다

감사합니다

왕초보

2019.02.14
16:17:34

처음에 시작이 어려지만...하나씩 배우시고..어느날...PE를 원하시는대로 셋팅을 할수 있게 되시면

점점더 배우는 재미가 있어지게 되실것이니다..

포기하시지 않으시면...아마..원하시는 형태의 PE로 마음대로 수정하시는 날이 오실것입니다

화이팅요...

DeePBLue

2019.02.14
16:13:04

정말 열정이 대단하십니다...

 

지니제스트

2019.02.14
17:00:11

.

왕초보

2019.02.14
18:17:43

동영상까지 소개를 하여 주셨네요..

개인적으로 많이 아쉽습니다....해결을 하셨다고 하셔서...dll이나 레지등으로 해결을 하셔서..기존 PE에서처럼 자연스럽게..

해상도가 변경이 되는줄 알았습니다..

 

저도 어제 해상도 문제가 있다는것을 알고...오늘 새벽에 테스트 하여 본것이 있습니다

 

a1.png

 

Prorgams.ini 에서..reg 파일을 등록하는 명령어가 있어서..이것으로  우클릭메뉴가 수정된 레지를 등록하고...

우클릭 메뉴에서...ScreenResolution.ini 를 로드해서 해상도를 변경후...탐색기를 재실행하는것을 해보았었습니다

 

ScreenResolution.ini  내용입니다

 

EXEC =ScreenResolution.exe /Confirm

KILL Explorer
 

간단합니다..그런데 이것이 아쉬운 부분이 있습니다.. 제니제스트님도 마찬가지 인것 같습니다....

 

ScreenResolution.exe가 실행되고 해상도가 변경이 되었지만...바탕화면과 작업표시줄이 적용되지 않은 상태에서..변경상태 저장을

클릭을 해야만..탐색기가 재시작 됩니다...보기가 좀 흉하죠...

 

아래는 최신 XPE에서...해상도 변경이 진행되는 과정입니다

 

1. 해상도 변경을 하면..화면이 커지고 아직..바탕화면과 작업표시줄이 적응하지 못한 순간입니다..

  동영상으로 찍은다음에 필요한 사지만 추출한것입니다..연속적으로 자연스럽게 진행이 됩니다

21.png

 

2. 작업표시줄이 먼저 적용이 되었습니다

22.png

 

3. 바탕화면까지 완전히 적용이 되었습니다..3장의 사진이 연속적으로 진행이 됩니다..이렇게 적용이 된 상태에서..적용이나 복원 버튼을 클릭하게 됩니다..

23.png

 

4. 원래 해상도 변경도 이런식으로 진행이 되죠..그래서..해상도 변경프로그램이 종료후 탐색기 재실행되는것이 조금..보기가 그랬었습니다

  좋은 아이디어가 있으시면 잘 부탁드립니다

 

 

 

 

 

첨부 :
a1.png [File Size:5.8KB/Download0]
21.png [File Size:408.6KB/Download0]
22.png [File Size:409.8KB/Download0]
23.png [File Size:523.2KB/Download0]

지니제스트

2019.02.14
18:56:35

.

왕초보

2019.02.14
19:08:34

RS5 17763.253 버전까지도 잘 되었던것이 갑자기 이런 현상이 생기는것을 보면..

이번에 윈도우가 업데이트 되면서 변화된 부분들이 있나 봅니다.

구버전 XPE로...RS5 17763.316 로 빌드했을 경우에도 같은 현상이 있는것을 보면..이제는 최신 XPE로 빌드하여야 하나 봅니다

 

우리두리님께서 방법을 찾고 있지 않을까 하고 기대를 하여 봅니다..

 

 

ehdwk

2019.02.14
19:36:20
수고하셨습니다.

gama

2019.02.17
19:59:13

나도 모르겠네요

List of Articles
[공지] 스크린샷 업로드 유의사항
XE1.8.27 Layout1.4.8